[sylpheed:32251] Re: Gutsy > Hardy upgrade deleted Sylpheed

Bob White bob at bob-white.com
Sun Apr 27 13:03:24 JST 2008

On Sat, 26 Apr 2008 20:10:08 -0700
John Jason Jordan <johnxj at comcast.net> wrote:

> I have a laptop (my main computer) which uses Sylpheed version 2.4.5 GTK
> + 2.12.0 / GLib 2.14.1. It works just fine. 
> I also have a desktop computer which I use for storage of backups from
> the laptop, and as a second computer in case something bad happens to
> the laptop (at least I can still get online to find out what went
> wrong). The desktop runs Sylpheed Claws, but I can't tell you what
> version because it is gone. More details follow.
> This morning I decided to upgrade to Hardy. I started with the desktop.
> During the upgrade it uninstalled Sylpheed Claws, claiming that it was
> obsolete software. I tried to reinstall from Synaptic but Synaptic
> refused, stating that Sylpheed Claws (GTK) had unresolved dependencies. 
> There's not much in the mail folders on the desktop because I set
> Sylpheed Claws there to leave messages on the server - the laptop is
> what I really use for e-mail, so that is where I want e-mails archived.
> In other words, the mail folders are expendable. Accordingly, I decided
> to try to install straight Sylpheed, which is also listed in Synaptic.
> That installation went fine, but it did not pick up the configurations,
> so all my mail accounts are gone. I could recreate them manually, but
> before I go to the trouble I thought I'd ask here what is going on. Why
> would a dist-upgrade delete Sylpheed Claws? What is wrong with the
> dependencies that keeps me from reinstalling it? And, assuming I cannot
> reinstall the original, how can I get my configuration back in the
> straight Sylpheed that I installed, without having to recreate my mail
> accounts?

Hello John,

First, I think Claws is supported somewhere else, so there may be a
better list to get Claws help. (They have also dropped the Sylpheed
part of the name.)  As to recreating the accounts, try copying them from
your laptop.  Sylpheed keeps all its information in ~/.sylpheed-2.0/ or
since Claws surely wasn't using that directory, copy it from the
directory Claws was using if it still exists. 

Not knowing much about Claws current development, I don't know how
compatible the account files are, but it used to be possible to move
between the applications.

Good Luck,
Bob W.

More information about the Sylpheed mailing list