[sylpheed:36870] Re: Sylpheed + GnuPG on Windows

Sijmen J. Mulder ik at sjmulder.nl
Wed Dec 4 22:13:56 JST 2019

"Sijmen J. Mulder" <ik at sjmulder.nl> wrote:
> Using Windows 10, Sylpheed 3.7.0, and GnuPG 2.2.15 (installed through
> Gpg4win) and selecting the option to warn at startup if GnuPG doesn't
> work, I get a message saying GnuPG is too old or couldn't be found.
> gpg from the command line and GNU Privacy Assistant work fine.
> Is there anything I can try to get this to work? Perhaps a way to get a
> bit more specific information out of Sylpheed?

I got back to debugging this today and (sort of) figured it out. Long
story short, I had to create a registry key:

  "Install Directory"="C:\\Program Files (x86)\\Gpg4win\\..\\GnuPG\\bin"

because Gpg4win uses a different key (without GNU\):


Full story:

1. Starting Sylpheed with --debug showed that gpgme returned an error
   "Invalid crypto engine".

2. Setting the GPGME_DEBUG environment variable to dig deeper revealed
   that gpgconfig was not found.

3. Using Sysinternal's Process Monitor tracer I discovered that
   Sylpheed (through GPGME) tried to access

     C:\Program Files (x86)\GNU\GnuPG\gpgconf.exe   

   but on my system it's located at:

     C:\Program Files (x86)\GnuPG\bin\gpgconf.exe

   When I created the expected directory and copied the files from bin\
   there it worked.

4. Further digging in Process Monitor showed that Sylpheed (through
   GPGME) accessed the "Installation Directory" value in registry key


   but Gpg4win had put its configuration in


   In addition, its "Installation Directory" pointed at the main
   directory, not the bin\ directory where the executables are. I
   created the expected key and value as shown above and now it worked,
   also after deleting the directory I created in step 3.

Maybe this helps someone.


More information about the Sylpheed mailing list