[sylpheed:36630] Sylpheed and high CPU usage in some folders

Antonio Ospite ao2 at ao2.it
Sat Oct 21 19:14:20 JST 2017


It's a week or so that Sylpheed 3.6.0 on my Debian unstable machine
takes a lot of CPU when exploring some folders with a lot of messages.

I am writing here instead of sending a Debian bug report or filing
a report on the redmine tracker in the hope of reaching a broader
audience, I can report elsewhere if appropriate.

Some details on my setup:
Sylpheed Version 3.6.0 (Build 1178)
GTK+ 2.24.31 / GLib 2.54.1
Operating System: Linux 4.13.0-1-amd64 (x86_64)
Compiled-in features: gthread IPv6 iconv compface GnuPG OpenSSL LDAP GtkSpell

CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4800+
Disk: Seagate Barracuda 7200.12

I can consistently see the behavior with "htop" or the Gnome system
monitor when I navigate my "alsa-devel" and "linux-input" mailing list
folders in Sylpheed, I can trigger the problem going to the next unread
message with the "Next" UI button.

Usually Sylpheed performs some disk activity but I've never saw this
very high CPU usage before.

>From a quick "perf" run it looks like most of the time is spent here:

85,55% sylpheed libgtk-x11-2.0.so.0.2400.31 [.] gtk_tree_store_get_path
12,58% sylpheed libglib-2.0.so.0.5400.0     [.] g_node_nth_child

I tried to recreate the .sylpheed_cache and .sylpheed_mark file in the
affected directories but nothing changed.

The Mail dir is on the local disk (a normal HDD but it shouldn't
matter), and the problem happens also with Sylpheed in off-line mode.

A self compiled binary from the latest svn trunk shows the same

Has anyone else noticed anything similar recently? Initially I thought
it could be caused by some update in dependency libraries in Debian, but
there was no update to gtk2 recently, and I tried to downgrade glib to
a previous version but with no changes.

I also tried with a Debian stable live image (Stretch 9.2 with Sylpheed
3.5.1) to exclude that the culprit was a recent update in Debian
unstable and the behavior is confirmed on Debian stable as well.

So it seems to be the data; could it just be that these particular
folders reached some limit Sylpheed is not comfortable with?

Just for reference Claws-mail 3.15.1 does NOT show the problem in the
same folders.

Please let me know any other info you might need.

If you want access to the Mail data which shows the problem here are the
steps to download the data and replicate the issue:

1. Get the mailing list data (it's about 850MB):

   $ wget "http://mailman.alsa-project.org/mailman/private/alsa-devel.mbox/alsa-devel.mbox?username=USERNAME&password=PASSWORD" -O alsa-devel.mbox
   replacing USERNAME with "alsa-devel at mailinator.com" and PASSWORD with
   "mailinator" in the link above. I am not pasting a full working link
   to reduce the risk of spamming the alsa-project server.

   I can share off-list an alsa-devel.mbox.bz2 file of about 163MB.
2. Import the alsa-devel.mbox file into a new folder in Sylpheed.

3. Click on the new folder in the folders view and go to the next
   message with the "Next" button.

You can see a very high CPU usage.

Now that I think of it I might have imported data into the affected
folders from the mbox archives at
http://mailman.alsa-project.org/pipermail/alsa-devel/ so maybe the
imported data is confusing Sylpheed (but not Claws-mail apparently)?
Just a thought.


Antonio Ospite

A: Because it messes up the order in which people normally read text.
   See http://en.wikipedia.org/wiki/Posting_style
Q: Why is top-posting such a bad thing?

More information about the Sylpheed mailing list