[sylpheed:34236] Re: Sylpheed 3.0.3 and Gpg4win 2.0.4 problem

Manfred Usselmann usselmann.m at icg-online.de
Tue Oct 5 19:40:23 JST 2010


On Tue, 5 Oct 2010 11:50:26 +0200
didier gaumet <didier.gaumet at gmail.com> wrote:

> Sylpheed 3.0.3 and Gpg4win 2.0.4 problem
> Under Windows Seven starter (french), if I use Sylpheed 3.0.3 with
> Gnupg 1.4.10 binary from ftp.gnupg.org, it works perfectly.
> However, this version of Gnupg being not installed and Gpg4win 2.0.4
> being installed instead, if I run Sylpheed, there is a message box
> saying that Gnupg is not installed correctly and Gnupg is deactivated
> in Sylpheed.  
> But Claws-mail works flawlessly with the Gpg4win version of Gnupg, so
> the problem seems to make Sylpheed recognize this version of Gnupg
> version properly: 
> Any hint of how to do that?

I was able to remove the startup error message by editing the registry
and changing 'HKCU\Software\GNU\GnuPG\gpgProgram' from




Additionally I set 'HKLM\Software\GNU\GnuPG\Install Directory' to 


Unfortunately Sylpheed is still not working 100% with GPG4WIN. A lot of
DOS windows are opened whenever a pgp related action is executed and
sametimes decryption or signature verification does not work. I believe
this is the case when Sylpheed and GPG4WIN are used to encrypt / sign
the message.

I can confirm that Claws does work without problems with GPG4WIN.


More information about the Sylpheed mailing list