[sylpheed:31508] sending message fails - sort of

Indriði Einarsson indridi.einarsson at gmail.com
Wed Jul 11 00:45:41 JST 2007

Hello all

First, thanks for this great email-client, I've been using it for a
while now, and like it at lot.

Only, recently it began behaving weird. Whenever I send an email, it
gets sent just fine, but after sending it (when the "sending dialog"
shows status "Quitting") an error dialog pops up, saying "Error
occurred while sending the message."

I have tried starting afresh, by removing the ~/.sylpheed-2.0
directory, but it didn't help. I have also tried shutting down all the
firewalls that might be getting in the way. This may or may not have
something to do with me playing around with fetchmail the other day,
but I've uninstalled all that now.

This happens in 2.4.1 (ubuntu feisty) as well as 2.4.3 (source from
the official sylpheed site). I haven't tried compiling the svn version

As I said, the mail is sent, but no matter what I do, it does'not get copied in the "sent" directory. I also had a filter copying sent messages to the inbox (for a nice thread view) but that stopped working too. I have of course tried shutting those options off, to no avail.

Here is the result of running sylpheed --debug, sending one message
and quitting:

[indridi at edelstoff][...download/sylpheed-2.4.3] sylpheed --debug
ssl_init(): /home/indridi/.sylpheed-2.0/certs doesn't exist, or not a directory.
ssl_init(): certs dir /etc/ssl/certs found.
looking for /home/indridi/.sylpheed-2.0/ca-certificates.crt
looking for /home/indridi/.sylpheed-2.0/ca-bundle.crt
looking for /home/indridi/.sylpheed-2.0/ca-root.crt
looking for /home/indridi/.sylpheed-2.0/certs.crt
looking for /etc/ssl/certs/ca-certificates.crt
ssl_init(): certs file /etc/ssl/certs/ca-certificates.crt found.
SSLv23 available
TLSv1 available
current dir: /home/indridi
current dir: /home/indridi/.sylpheed-2.0
current dir: /home/indridi
Reading configuration...
Found [Common]
Finished reading configuration.
Reading filter configuration...
Reading /home/indridi/.sylpheed-2.0/filter.xml
Reading actions configurations...
Reading configuration for displaying headers...
GpgME Protocol: OpenPGP
      Version: 1.4.6
GpgME Protocol: CMS
      Version: 2.0.3
Creating main window...
Creating folder view...
Creating summary view...
Creating message view...
Creating header view...
Creating text view...
Creating MIME view...
Creating text view...
Creating image view...
Creating log window...
Setting widgets... done.
summary_set_column_order: pos 0 : type 0, vislble 1
summary_set_column_order: pos 1 : type 1, vislble 1
summary_set_column_order: pos 2 : type 2, vislble 1
summary_set_column_order: pos 3 : type 3, vislble 1
summary_set_column_order: pos 4 : type 4, vislble 1
summary_set_column_order: pos 5 : type 5, vislble 1
summary_set_column_order: pos 6 : type 6, vislble 1
summary_set_column_order: pos 7 : type 7, vislble 0
Reading all config for each account...
Found label: Account: 1
Found label: Account: 2
current locale: is_IS.iso88591
Reading configuration...
Found [Account: 1]
Finished reading configuration.
Reading custom header configuration...
Reading configuration...
Found [Account: 2]
Finished reading configuration.
Reading custom header configuration...
Setting folder info...
empty folder

Reading address index...
Creating LDAP server interface object
added timer = 67
removed timer = 67
Creating progress dialog...
getting new messages of account gmail...
LibSylph-Message: Connecting to POP3 server: pop.gmail.com...

Reloading /etc/resolv.conf
SSL connection using DES-CBC3-SHA
Server certificate:
  Subject: /C=US/ST=California/L=Mountain View/O=Google Inc./CN=pop.gmail.com
  Issuer: /C=US/O=Equifax/OU=Equifax Secure Certificate Authority
SSL verify OK
session (0x8749800): connected
[17:38:45] POP3< +OK Gpop ready for requests from p56pf3859820uga
[17:38:45] POP3> USER indridi.einarsson at gmail.com
[17:38:46] POP3< +OK send PASS
[17:38:46] POP3> PASS ********
Creating compose window...
addressbook_load_completion... done
start_address_completion ref count 1
template.c:126 reading templates dir /home/indridi/.sylpheed-2.0/templates
compose_exec_ext_editor(): pid: 17340 file: /home/indridi/.sylpheed-2.0/tmp/tmpmsg-0x876d8d0.txt
[17:38:46] POP3< +OK Welcome.
[17:38:46] POP3> STAT
[17:38:47] POP3< +OK 0 0
[17:38:47] POP3> QUIT
[17:38:48] POP3< +OK Farewell.
session (0x8749800): closed
session (0x8749800): destroyed
inc_finished(): 0 new message(s)
added timer = 150
Compose: child exit (pid: 17340 status: 0)
Set_undo - Testpoint
src encoding = UTF-8, out encoding = ISO-8859-1, body encoding = ISO-8859-1, transfer encoding = quoted-printable
generated Message-ID: 20070710173910.0c2e53bc.indridi.einarsson at gmail.com
Creating progress dialog...
LibSylph-Message: Connecting to SMTP server: smtp.gmail.com ...

send_message_smtp(): begin event loop
session (0x8749800): connected
[17:39:11] SMTP< 220 mx.google.com ESMTP s1sm1865430uge
domain name = localhost.localdomain
[17:39:11] ESMTP> EHLO localhost.localdomain
[17:39:12] ESMTP< 250-mx.google.com at your service, []
[17:39:12] ESMTP< 250-SIZE 28311552
[17:39:12] ESMTP< 250-8BITMIME
[17:39:12] ESMTP< 250-STARTTLS
[17:39:12] ESMTP> STARTTLS
[17:39:12] ESMTP< 220 2.0.0 Ready to start TLS
SSL connection using DES-CBC3-SHA
Server certificate:
  Subject: /C=US/ST=California/L=Mountain View/O=Google Inc/CN=smtp.gmail.com
  Issuer: /C=ZA/ST=Western Cape/L=Cape Town/O=Thawte Consulting cc/OU=Certification Services Division/CN=Thawte Premium Server CA/emailAddress=premium-server at thawte.com
SSL verify OK
[17:39:12] ESMTP> EHLO localhost.localdomain
[17:39:13] ESMTP< 250-mx.google.com at your service, []
[17:39:13] ESMTP< 250-SIZE 28311552
[17:39:13] ESMTP< 250-8BITMIME
[17:39:13] ESMTP< 250-AUTH LOGIN PLAIN
[17:39:13] ESMTP> AUTH PLAIN ********
[17:39:14] ESMTP< 235 2.7.0 Accepted
[17:39:14] SMTP> MAIL FROM:<indridi.einarsson at gmail.com>
[17:39:14] SMTP< 250 2.1.0 OK
[17:39:14] SMTP> RCPT TO:<indridi at indridi.net>
[17:39:14] SMTP< 250 2.1.5 OK
[17:39:14] SMTP> DATA
[17:39:15] SMTP< 354 Go ahead
[17:39:15] SMTP> . (EOM)
[17:39:16] SMTP< 250 2.0.0 OK 1184081901 s1sm1865430uge
[17:39:16] SMTP> QUIT

(sylpheed:17334): LibSylph-WARNING **: SSL_read() returned error 1, ret = -1

(sylpheed:17334): LibSylph-WARNING **: session_read_msg_cb: sock_read: Success

(sylpheed:17334): LibSylph-WARNING **: [17:39:17] Error occurred while sending the message.

Creating alert panel dialog...
session (0x8749800): closed
session (0x8749800): destroyed
Creating alert panel dialog...
return value = 0
mh_scan_folder(): Scanning queue ...
current dir: /home/indridi/Mail/queue
Last number in dir queue = 0
removed timer = 150
Found [Common]
Configuration is saved.
Writing filter configuration...
Saving address books...
Exporting addressbook to file...
Invalidation request for address completion
addressbook_load_completion... done
[indridi at edelstoff][...download/sylpheed-2.4.3]  

Hope someone can find out something about this.

Kind regards

Indriði Einarsson <indridi.einarsson at gmail.com>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.sraoss.jp/pipermail/sylpheed/attachments/20070710/698be6ea/attachment.bin 

More information about the Sylpheed mailing list