[sylpheed:30976] Re: "error occured while processing messages"(2)

Andrei Mircea mircea.andrei at wanadoo.fr
Mon Feb 19 18:49:32 JST 2007

On Sun, 18 Feb 2007 23:18:30 +0000
Andrei Mircea <mircea.andrei at wanadoo.fr> wrote:

> On Sun, 18 Feb 2007 12:16:45 +0100
> Pavlos Parissis <p_pavlos at freemail.gr> wrote:
> > On Sun, 18 Feb 2007 10:59:02 +0000
> > Andrei Mircea <mircea.andrei at wanadoo.fr> wrote:
> > 
> > > Hello,
> > > I just realized that I have a problem when trying to move messages from the
> > > input folder to another folder. I get an error window with the text
> > > reproduced in the subject of the present message.
> > 
> > I cannot reproduce the problem in Debian Sarge with Sylpheed 2.4.0beta4.
> > What do you see on the log?
> > 
> > Try to start sylpheed in debug mode and check the permission on the directories.
> > 
> > >In Windows this does not
> > > happen. I tried both with the recent Sylpheed version 2.4.0beta3 and with an
> > > older one (2.2.9), the same error arises. Where should I look for a
> > > solution ? thank you in advance. Andrei
> > 
> I understood what happens. The error arises when the destination folder is a sub-folder in another folder in Mail. I have a folder called "software" and in it there are many sub-folders corresponding to various software companies or authors. The Mail folder is situated in a fat32 partition (I access it either from Linux or from Windows). The error occurs when I try to move a message in one of these sub-folders; it does not occur when I move in one of the folders directly under Mail. The error is accompanied by a message on the console from which I launch XWindows. For instance, for a sub-folder called "boxer", the message is:
> /mnt/hdc5/Mail/soft\boxer: chdir: No such file or directory
> therefore the problem is due to the anti-slash character appearing there instead of a slash one. And indeed, in folderlist.xml, the paths to these sub-folders are written with anti-slash, e.g.  
> 	...name="boxer" path="soft\boxer"...
I converted all those anti-slashes in slashes, then tested how it works in this situation. It works well both when Sylpheed is accessing the Mail folder from Linux and from Windows

More information about the Sylpheed mailing list